Start a conversation

History Not Displaying for LanGuard Program Updates Activity

Overview 

  • When opening the Program Updates Activity under the Activity Monitor tab, the update history shows blank.
  • The updatehistory.xml file located at C:\ProgramData\GFI\LanGuard 11\Update\ has no content, or is empty.

 

Environment 

  • GFI LanGuard
  • Any supported environment

 

Root Cause

The updatehistory.xml file has become corrupted and needs to be rebuilt.

 

Process

Follow these steps to resolve this issue:

  1. Download a new updatehistory.xml file from GFI FTP.
  2. Unpack the archived package.
  3. Close the LanGuard console.
  4. Stop related services.
  5. Replace the updatehistory.xml file located at C:\ProgramData\GFI\LanGuard 11\Update\ with the newly downloaded one.
  6. Restart the services.
  7. Open the LanGuard console.

NOTE: Upon re-opening the console, the Program Updates Activity will show as blank, and entry listings will start again on the next program updates.

 

Related Article

Recommended Settings for Best Performance in GFI LanGuard

 

Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted

Comments