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Reports show "No records matching the current criteria were found!"

Answer

PROBLEM

Generated reports show the following message in report sections: No records matching the current criteria were found! ,although data is available for this report which can be seen in the scan results for the computer(s) or in the dashboard sections.

ENVIRONMENT

  • GFI LanGuard 2014 R2 and later
  • Microsoft SQL Server backend database
  • All supported platforms

SOLUTION

Please verify the following debug log file in C:\ProgramData\GFI\LanGuard 11\Debuglogs\lanss_v113_configtools.csv OR C:\Documents and Settings\All Users\Application Data\GFI\LanGuard 11\DebugLogs\lanss_v113_configtools.csv (on a Microsoft Windows 2003 class computer)

Search for the line similar to this:
"error ","CommonUtils","GenericDbConnection.GetDataSet - Error System.Data.SqlClient.SqlException (0x80131904): Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.

If you find a match, please increase the Microsoft SQL command timeout per the following article: How to extend the Microsoft SQL timeout in GFI LanGuard

CAUSE

The reports in question may have queries that take a long time to process the available data and therefore it times out before a report is generated.
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  1. Priyanka Bhotika

  2. Posted

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