Start a conversation

How to extend the Microsoft SQL timeout in GFI LanGuard

Answer

PROBLEM

GFI LanGuard may encounter errors when attempting to load / save data into the Microsoft SQL database. This will show up in the 2 logs as 'timeout expired'.

lanss_vXXX_configtools.csv:
..."error ","CommonUtils","GenericDbConnection.GetDataSet - Error System.Data.SqlClient.SqlException (0x80131904): Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding. 

lanss_vXXX_reporting.csv:
..."error ","Exporter","ExportScanResultsFromDatabase::ExportToXmlFile COM error HRESULT '-2147217871' message 'IDispatch error #3121' source 'Microsoft OLE DB Provider for SQL Server' description 'Timeout expired'."
..."info ","Exporter","ExportScanData scanSessionID '92926029' filename 'D:\GFI Languard Scan Results\Aug 2017\scanresultxml_Desktop Scan.txt_2017_08_03_145414.xml' result '-2'<<"
..."error ","Exporter","ExportScanResultsFromDatabase::ExportToXmlFile COM error HRESULT '-2147217871' message 'IDispatch error #3121' source 'Microsoft OLE DB Provider for SQL Server' description 'Timeout expired'."
 

ENVIROMENT

  • GFI LanGuard
  • Microsoft SQL 2005 or higher  (including Microsoft SQL Express edition)

SOLUTION

  1. Backup the toolcfg_database.xml file in the installation folder of GFI LanGuard.
  2. Edit the file with notepad.
  3. Find the following section:
<Option Name="ScanHistory_RemoveOlderThanValue"><![CDATA[36]]></Option>
  1. Add a line after the </Option> tag and then paste in the following 2 lines:
<!-- Command timeout in seconds. --> 
<Option Name="Timeout"><![CDATA[300]]></Option>
  1. Save the changes in the file
  2. Restart the GFI LanGuard Attendant service and open the GFI LanGuard console.

CAUSE

Microsoft SQL server may timeout due to disk or network I/O, or lack of resources.
Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted

Comments