Overview
While the Kerio Connect server is facing a High Open Folder count issue (e.g. INBOX, Sent Items), the performance in the admin GUI (search results in Outlook/Webmail, general responsiveness) can be decreased. Due to a large mailbox, the index.fld files may become corrupted.
The following errors may be generated:
folder_manager.cpp: Cannot open folder ~(mailaddress-foldername): locked after X retries.
MessageIndexCache.cpp: Cannot open index file /Kerio_message_store/store/mail/domain.com/johndoe/Sent Items/index.fld in mode rb: (2) No such file or directory
Prerequisites
Access to Kerio Connect server
Diagnosis
The user mailbox is experiencing slowness because of folder corruption (a large number of items per each folder), file System errors (wrong read/write permissions), or the Kerio Connect server being under DDoS attack (failed user account attempts, failed SMTP/IMAP logins).
Solution
Note: the below recommendations are considered as best-practices.
- Keep less than 10,000 items in each folder. If there are folders with over 10,000 items, please split those folders into smaller subfolders. For more information, please refer to Slow search and Performance with the Kerio Outlook Connector.
- Limit User Access by setting Kerio Connect service restrictions. For more information, please refer to Client Mail Timeout Issues Due to Multiple Open Folders.
- Re-index User Folder manually and check the file/folders System permissions. Kerio Connect should be installed under the Admin/root user account.
- Secure Kerio Connect using Firewall settings. Add the reported suspicious IP addresses to the firewall blacklist. If you're using Kerio Control, consider Enabling Protection from DDoS Attacks.
Confirmation
The user Mailbox performance is back to normal.
Priyanka Bhotika
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