Overview
A user has deleted some emails from their Sent Items, Deleted Items, and INBOX folders (Calendars, Contacts, etc.) and as a result, the user is unable to access emails in Webmail and Outlook.
The data restoration can be performed using Kerio Connect recovery from full or differential server backup files. The data might be stored in a 3rd-party external backup or using the Kerio Connect built-in backup functionality.
Prerequisites
Admin access to the Kerio Connect server
Diagnosis
The Kerio mailbox is structured as below:
\store\mail\domain.com\username\INBOX\#msgs
\store\mail\domain.com\username\Sent Items\#msgs
\store\mail\domain.com\username\Calendar\#msgs
\store\mail\domain.com\username\Contacts\#msgs
The emails, calendars, and contacts have the .eml
extension, but the filename is randomly generated in hex format (e.g., 0000000a.eml
).
- From the backup, you need to locate the missing items and copy them to the appropriate
#msgs
folder. - If, for instance, the filename already exists, you can change the filename as long as it is in hex format.
- If you are not sure how to change the filename, you can follow the format of the filenames in that folder. For example, if the newest file is
0000000a.eml
, you can change it to0000000b.eml
.
The challenge here is how to check if you have the correct item to restore, as you will need to open the .eml
file in Outlook or Notepad. You can also try the native search in Windows or run scripts to search for the emails (if you know specific keywords in the email like the recipient, etc.).
Solution
If the User Has an External Backup (Using Third-Party Backup Software):
-
Locate the Sent Items and Deleted folders in the external backup.
-
Copy the
.eml
files from the...Sent Items/#msgs
and...Deleted/#msgs
folder to the current folders.
If the User Has a Standard Kerio Connect Built-In Backup Functionality:
-
Check the
.eml
files in the last full backup.
-
Move the necessary or missing
.eml
files to the current folders.To recover specific domain Public folder, copy.eml
files to this folder:[domain]/#public/[folder_name]/#msgs
.For example, in the Windows environment, it will be similar to
C:\Program Files\Kerio\MailServer\Store\Mail\[domain]\#public\[folder_name]\#msgs
.
Additional Steps
After restoring the emails from a backup, the user needs to re-index the affected mailbox.
Related Articles
- Creating a Full Backup of Kerio Connect Data
- Recovering Kerio Connect Data on Windows
- Recovering Kerio Connect Data on Linux
- Recovering Domain Public Folders on Windows
Priyanka Bhotika
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