Overview
Kerio Connect Archiving feature uses compressed ZIP archives to store the data. Once the data is stored, it appears in Webmail or Kerio Connect Client archive folders. If the folders are not visible, the users won't be able to access historical mailbox items.
The archived emails can be restored manually using standard decompression functionality, then copying files and re-indexing the necessary user mailbox. The standard folder structure for Monthly Archive is the following.
Prerequisites
The user should have Archive Folder rights in Folder Administration.
Root Cause
Kerio Connect is not re-indexing Archive folders, and it is unable to recognize a folder that does not have status.fld
file in it.
Solution
-
Create a new user with any name.
Note: You can use an existing user, but the new user will reduce re-indexing time that will be required later. -
From the newly created user's webmail, create a new folder for Archive, for example, 2019-Dec.
-
Open the old 2019-Dec folder containing the archived emails and navigate to the #msgs subfolder. Copy all the
.eml
files from the #msgs subfolder.The directory structure of 2019-Dec will be similar:
-
Navigate to the new folder 2019-Dec, open the #msgs subfolder located in the user directory from step 1 and paste all the
.eml
files from step 3 to the #msgs subfolder. The default location would be\MailServer\Store\Mail\[domain]\[username]\2019-Dec
. -
Re-index the mailbox of the newly created user from step 1.
-
Check if the emails from the old Archive are visible in a new folder in the user webmail.
-
Move the 2019-Dec folder from the user directory to the Archive directory. The default location would be
\MailServer\store\archive
.
Confirmation
The new folder 2019-Dec is visible under Archive Folders.
Alternative Workaround
Archive Folders Are Not Visible in Webmail
Priyanka Bhotika
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