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Calendar is unavailable in Outlook with MAPI_E_LOGON_FAILED error

Overview

When sharing mail and calendar folders with other users, the second user cannot view the Calendar folder. The shared folder is being added using additional mailboxes in the Kerio Outlook Connector (KOFF) profile.

OutlookAdditionalMailboxes.png

While clicking the checkbox to enable the Calendar folder, the user gets This folder group cannot be opened 0x8004011 MAPI_E_LOGON_FAILED error.

OutlookCalendar.pngClientErrorMAPI-E-LOGON.png

Prerequisites

Administrator (root) access to the Kerio Connect server

Diagnosis

Traditional MAPI connections used in Kerio Connect are no longer supported, as they have moved to support RPC over HTTP only. The MAPI libraries installed on the PC might be either corrupted or outdated.

Workaround

Note: for detailed guidance please refer to Recreating an Outlook Profile When Using the Kerio Connector.

  1. Remove the Outlook profile
  2. Stop Kerio Connect
  3. Navigate to the store folder.
  4. Remove the folder '__keriomapi__STORE' and the file specguid.fld and .journal.db
  5. Start Kerio Connect
  6. Create the Outlook profile again, check Creating profiles in MS Outlook for further reference.

Confirmation

The shared Calendar folder is visible in KOFF.

Choose files or drag and drop files
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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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