Start a conversation

Delete, Rename, Store and Expunge Commands Are Not Working for Old Emails When Accessing the Archive via IMAP4 After Upgrading to GFI MailArchiver 2014 or Newer

Overview

When accessing GFI MailArchiver 2014 or newer using IMAP the DELETE, RENAME, STORE and EXPUNGE commands are not working for old emails after upgrading from an earlier version.

For example:

  1. GFI MailArchiver 2013 was running with the IMAP server enabled.
  2. The installation has been upgraded to GFI MailArchiver 2014 or newer.
  3. Archived emails (through the newer version) can be deleted successfully using IMAP, however, emails (which got synchronized into the IMAP database before the upgrade) cannot be deleted.

Environment

  • GFI Archiver
  • Using GFI Archiver's IMAP server to access emails

Root Cause

This occurs only when upgrading from earlier versions. Email metadata (which got synchronized to the IMAP meta-database before the upgrade) does not allow to execute deletion or rename functionality.

Resolution

On the computer where GFI Archiver is installed, delete the IMAP meta-database, so that all emails in the meta-database can be re-synchronized from the Archive Stores. Perform the following actions:

  1. Log in with a user that has administrative privileges.
  2. Stop the GFI Archiver IMAP service.
  3. Open the GFI Archiver installation folder, navigate to ..\InstallationFolder\IMAP\Data\DB and locate IMAPDB.FDB.
  4. Delete the IMAPDB.FDB file.
  5. Start the GFI Archiver IMAP service.

NOTE: When the GFI Archiver IMAP service is re-started, GFI Archiver will re-synchronize the emails from the Archive Stores into the IMAP meta-database. The users’ archive mailboxes (via IMAP) will be temporarily empty until all emails have been re-synchronized and the IMAP cache has been rebuilt.

Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted

Comments