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Scheduled Scans and Patch Deployments Not Running

Overview

A scheduled scan is a network audit that is scheduled to run automatically on a specific date/time and at a specific frequency. GFI LanGuard ships with a patch auto-deployment feature that enables you to deploy missing patches and service packs in all languages supported by Microsoft® products.

At times, the following GFI LanGuard remote actions might not be running as required:

  • Scheduled scans configured from the console.
  • Scheduled scans configured from the agents.
  • Patch deployments.

This article analyzes the root cause of this issue, along with the available solution to fix the remote actions mentioned above.

 

Root Cause

The file agentmanagercom.dll is not registered correctly in the GFI LanGuard server.

 

Resolution

  1. Log in to the GFI LanGuard server. 
  2. Close the GFI LanGuard.
  3. Stop all the LanGuard services.
  4. Open the Command Prompt in elevated mode:

    1. Click Start.
    2. Type cmd in the search box.
    3. Right-click on cmd.exe and choose Run as Administrator.
    4. In the User Account Control window, click Yes to run the Windows Command Prompt as an administrator.
  5. Run the following command:
    regsvr32 C:\Program Files (x86)\GFI\LanGuard xx\agentmanagercom.dll
    NOTE: Replace xx in the above path with the version number of the GFI LanGuard.
  6. Start GFI LanGuard.
  7. Reopen the console.
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  1. Priyanka Bhotika

  2. Posted

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