Overview
When deploying patches to a system, the following error is encountered:
The service did not start due to a logon failure.
Information
Environment
GFI LanGuard
Root Cause
The account used to execute the patch installers using GFI LanGuard Patch Agent service does not have permission to log on to the system as a service.
Process
Check the Account That Runs GFI LanGuard Patch Agent Service
- Go to Advanced options > Deploy patches under the following administrative account
- If not enabled by GFI LanGuard, it uses the Local System account on the target machine that does not produce the error.
- If enabled, it uses the account and the password specified as shown below:
Enable 'Log on as a Service' on the Remote Computer
NOTE: If you want to set this policy for the entire domain, perform using the domain security policy snap-in.
- Open the Control Panel on the remote system.
- Go to Administrative Tools > Local Security Policy.
- Navigate to Computer Configuration > Windows Settings > Security Settings > Local Policies > User Rights Assignment.
- Find the Log on as a service policy and add the appropriate user or group.
- Click Apply, then OK.
Confirmation
The patches are deployed successfully.
Priyanka Bhotika
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