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Unable to Deploy Patches - Error: The service did not start due to a logon failure.

Overview

When deploying patches to a system, the following error is encountered:

The service did not start due to a logon failure.

Information

Environment

GFI LanGuard

Root Cause

The account used to execute the patch installers using GFI LanGuard Patch Agent service does not have permission to log on to the system as a service.

 

Process

Check the Account That Runs GFI LanGuard Patch Agent Service

  • Go to Advanced options > Deploy patches under the following administrative account
    • If not enabled by GFI LanGuard, it uses the Local System account on the target machine that does not produce the error.
    • If enabled, it uses the account and the password specified as shown below:

      2019-07-30_6-58-07.png

Enable 'Log on as a Service' on the Remote Computer

NOTE: If you want to set this policy for the entire domain, perform using the domain security policy snap-in.

  1. Open the Control Panel on the remote system.
  2. Go to Administrative Tools > Local Security Policy.
  3. Navigate to Computer Configuration > Windows Settings > Security Settings > Local Policies > User Rights Assignment.
  4. Find the Log on as a service policy and add the appropriate user or group.
  5. Click Apply, then OK.

    2019-07-30_7-00-18.png

Confirmation

The patches are deployed successfully.

Related Article

Patch Deployment Process in GFI LanGuard

2019-07-30_7-00-18.png

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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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