Overview
GFI LanGuard Attendant service (lnssatt.exe) is not running and can not be restarted. One of the following error messages is displayed in the LanGuard console:
Attendant Service stopped due to Attendant Service not running.
or
Scheduled operations disabled due to stopped attendant service. Click here to restart.
Prerequisites
An account with local or domain Administrator privileges.
Diagnosis
Verify that the problem is still there:
- Open the Services panel by going to Control Panel > System and Security > Administrative Tools > Services.
- Locate the GFI LanGuard 12 Attendant service and, if it isn't running, right-click on it and try to Start.
- If it is starting without problems, that means that the problem is gone and the Attendant service can be (re)started.
If the Attendant service indeed is failing to start, the most common scenario is the problem with the user account specified to run the service. Possible reasons for this are:
- password expired due to domain password policy settings
- user account removed from the local administrator's group due to GPO policy
- manual changes to the Domain administrators group members
Follow these steps to diagnose the problem:
- While still in the Services panel double click the GFI LanGuard 12 Attendant service and select the Log on tab. Notice the account specified to start the service in your case for later steps:
- Right-click on Start > Computer Management, in the opened window, go to Local Users and Groups > Groups and double click on the Administrators group. Verify that user above belongs to this group. If it isn't, that is the root cause, proceed to the Solution section.
- For local user account go to Local Users and Groups > Groups and double click on user:
- If account is disabled or locked out, that is the root cause, proceed to the Solution section.
- For domain user account ask the administrator to check user account properties in Active Directory.
- Try to run any program as the user above and check whether password is correct.
- If all checks above passed we still can run Attendant Service using another account with local administrative rights.
Solution
Fix the problem with user account specified to run the Attendant Service found by the Diagnosis, if any:
- Add it to the local Administrators group
- Enable/Unlock it
- Enter the correct password in the Log On tab for the GFI LanGuard 12 Attendant service
If there were no problems found during the Diagnosis, change the account used by GFI LanGuard 12 Attendant Service:
- Open the Services panel by going to Control Panel > System and Security > Administrative Tools > Services.
- Double click the GFI LanGuard 12 Attendant service.
- Select the Log On tab and in the Log on: section select This account.
- Specify an account having Local administrative rights in the format <Domain>\<User> or just browse to the admin user.
- Provide the correct password for the specified account.
- Click the Apply button.
Testing
Start the Attendant service, launch the LanGuard console, and verify that the error message is gone.
If the service still fails to start, it is most likely local environment settings problem and should be troubleshooter starting with examining corresponding service start errors in the Windows Events logs.
Priyanka Bhotika
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