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Editing MailEssentials Config.mdb for Fixing Various Issues

Overview

This article shares the process for editing Config.mdb to resolve any of the following or additional similar issues:

  • Quarantine or Spam Digest not being delivered to users or administrator.
  • Emails released from the Quarantine are not delivered.
  • Administrator doesn't receive any notification emails.
  • Emails downloaded with Pop2Exchange are not delivered.
  • Forward to Email action does not work.
  • Autoreplies do not get sent.

 

Environment

  • GFI MailEssentials
  • Microsoft Exchange 2007
  • Microsoft Exchange 2010

 

Root Cause

MailEssentials Config.mdb has missing information in the tables:

  • tb_exchenv
  • tb_general

 

Process

Follow these steps to edit and correct settings for MailEssentials Config.mdb on a machine: 

  1. Close the MailEssentials Configuration console.

  2. Disable the GFI MailEssentials Scan Service.

  3. Stop all GFI MailEssentials services.

  4. Make a copy of config.mdb. Note that in MailEssentials 2012, the config.mdb referenced is located in the folder: MailEssentials\Antispam

  5. Open the config.mdb file in Microsoft Access.

  6. Open the table tb_exchenv

  7. Verify the correct version of Microsoft Exchange is showing in the modexch column from values as seen here:
    • 3 = installed on exchange 2007
    • 4 = installed on exchange 2010

  8. Ensure the Exchange roles are represented with the value -1 in the relevant columns. 

    For example, if the Exchange Hub and Mailbox roles are installed on the server, set the value to -1 in the following columns:
    • ismailboxserver
    • ishubtransportserver

  9. Open the table tb_general

  10. Verify that the Path and Pickup/Replay directories are correct for the Exchange under the columns:
    • replaydirectorypath
    • pickupdirectorypath

  11. In case there are incorrect Pickup/Replay directories, installation and troubleshooting logs must be carefully evaluated before fixing the config.mdb.

  12. Save changes to the config.mdb.

  13. Replace the original config.mdb file with the updated one.

  14. Restart all GFI MailEssential services.
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  1. Priyanka Bhotika

  2. Posted

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