Overview
This article shares the process for editing Config.mdb to resolve any of the following or additional similar issues:
- Quarantine or Spam Digest not being delivered to users or administrator.
- Emails released from the Quarantine are not delivered.
- Administrator doesn't receive any notification emails.
- Emails downloaded with Pop2Exchange are not delivered.
- Forward to Email action does not work.
- Autoreplies do not get sent.
Environment
- GFI MailEssentials
- Microsoft Exchange 2007
- Microsoft Exchange 2010
Root Cause
MailEssentials Config.mdb has missing information in the tables:
tb_exchenv
tb_general
Process
Follow these steps to edit and correct settings for MailEssentials Config.mdb on a machine:
- Close the MailEssentials Configuration console.
- Disable the GFI MailEssentials Scan Service.
- Stop all GFI MailEssentials services.
- Make a copy of config.mdb. Note that in MailEssentials 2012, the config.mdb referenced is located in the folder: MailEssentials\Antispam
- Open the config.mdb file in Microsoft Access.
- Open the table
tb_exchenv
- Verify the correct version of Microsoft Exchange is showing in the
modexch
column from values as seen here:- 3 = installed on exchange 2007
- 4 = installed on exchange 2010
- Ensure the Exchange roles are represented with the value
-1
in the relevant columns.
For example, if the Exchange Hub and Mailbox roles are installed on the server, set the value to-1
in the following columns:ismailboxserver
ishubtransportserver
- Open the table
tb_general
- Verify that the Path and Pickup/Replay directories are correct for the Exchange under the columns:
replaydirectorypath
pickupdirectorypath
- In case there are incorrect Pickup/Replay directories, installation and troubleshooting logs must be carefully evaluated before fixing the config.mdb.
- Save changes to the config.mdb.
- Replace the original config.mdb file with the updated one.
- Restart all GFI MailEssential services.
Priyanka Bhotika
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