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MailEssentials | Approved Quarantined emails are landing on the C: drive and not the Exchange Pickup folder

Answer

PROBLEM

  • When the user approves emails in the quarantine they are not delivered. When looking at the C: it shows .eml messages building up.

ENVIRONMENT

  • GFI MailEssentials
  • Microsoft Exchange 2007 or later

SOLUTION - Customer Friendly

  1. Open a run window and
  2. Enter the following command:
  • C:\Program Files (x86)\GFI\MailEssentials\e2k7wiz.exe clean

Notes

  • The command needs to have 'clean' parameter else it will just install/refresh the transport agents/sinks.
  • When using clean, the post-install wizard will ask user to reconfigure/validate the general settings, particularly asking to choose a default AntiSpam action for the modules. Make a note of what actions were set to the AS filters in case they need to be changed

SOLUTION - Manual, avoids changing the default AS action

  1. Grab a copy of the Config.mdb and the avapicfg.mdb from the server
  • Config.mdb is located ..\GFI\MailEssentials\Antispam
  • avapicfg.mdb is located ..\GFI\MailEssentials\EmailSecurity\Data
  1. Open the Config.mdb and locate the tb_general table make sure that its pointing to the correct version of Exchange
  2. Navigate to the tb_exchenv table. Adjust the modexch to the correct version of Exchange and adjust the correct roles that are installed on the customers environment.
  3. Open the avapicfg.mdb and locate the tb_general tab. Find the pickupdirectory and replay directory and enter the correct pickup paths for the clients Exchange.
  4. Navigate to tb_exchenv. Select the correct version of Exchange that the customer is running and roles that are installed on the clients environment. Note: Should be similar to step 3.
  5. Replace the customers databases with the corrected versions from the following steps
  6. Stop the Microsoft transport service
  7. Stop all GFI services
  8. Rename avapicfg.mdb to avapicfg.old and copy in the new database
  9. Rename the config.mdb  to config.old and copy in the new config.mdb
  10. Start all GFI services
  11. Start the Microsoft transport service

CAUSE

During the upgrade process, the incorrect version of Microsoft Exchange server was detected or the pickup paths were not added into the two databases. When releasing the email it will drop it in the C: since it cannot locate the C:\inetpub\mailroot\pickup folder.
Choose files or drag and drop files
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  1. Priyanka Bhotika

  2. Posted

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