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'Q8 or P4' When Trying to Approve Emails in Quarantine

Overview

When trying to approve an email from the quarantine, the user gets an error on the site saying either 'Q8 or P4; failed to approve' message.

Environment

  • GFI MailEssentials
  • Microsoft Exchange 2007 and later

Root Cause

Because MailEssentials has a misconfigured config.mdb, it does not know where to send emails once they have been approved. Normally, they get placed into the pickup folder but without a proper version of Exchange listed, the quarantine gives up.

If MailEssentials was previously installed on the Microsoft Exchange server and was moved to a relay server, the tb_exchenv and tb_general may still be populated with the Exchange information, which will also cause the above error.

In this case, remove the replay and pickup paths from the tb_general table and set all fields to 0 in the tb_exchenv table.

Resolution

  • Edit config.mdb in the tb_exchenv table so that the proper version of Microsoft Exchange is listed.
  • Make sure that in tb_general the correct pickup and reply folders are listed as well.
  • Please note that Microsoft Access will need to be installed in order to edit the file.
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  1. Priyanka Bhotika

  2. Posted

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