Overview
- Remote registry failed.
- RPC not available.
- The network path was not found.
lanss_v102_patchdeployment.csv
log:
"warning","RemediationEngine","Failed to open SC Manager: The RPC server is unavailable" "info ","RemediationEngine","<< TRemoteRegistryServiceManager.StartRemoteRegistryEx Result: False, dwLastError: 1722" "info ","RemediationEngine","<< StartRemoteRegistry Result: False" "warning","RemediationEngine","Registry connection failed Error 53: The network path was not found"
This article provides two possible solutions based on a couple of root causes found on why users are getting the errors when remediating in GFI LanGuard.
Environment
GFI LanGuard
Root Cause Analysis
Diagnosis 1
These errors are normally caused when the account used to connect to the target machine specified under Credentials and copied over the requisite files for remediation (Patchagent.exe
, deploypatches.bat
, patch install files, etc.) does not have full administrative access to the machine.
Solution 1
Ensure the account specified in Remediation Center > Remediate button > Credentials is part of the target machine's Administrators group (directly or via another group).
Diagnosis 2
The Remote Registry Service or Remote Procedure Call service is not enabled.
Solution 2
- Access Services or go to Run > Start and type
services.msc
. - Ensure the following services are started on the target machine:
- Remote Registry Service
NOTE: This can be set to Manual startup and LanGuard will attempt to start it.
For troubleshooting purposes, however, have the service running. - Remote Procedure Call Service (RPC)
- Remote Registry Service
Additional Step
Ensure the other requirements are met according to the following article:
Requirements for Windows Vista or Later Machines to Allow GFI LanGuard to Scan and Deploy Updates
Confirmation
Users should be able to remediate or apply software updates without receiving any of the mentioned errors above.
Priyanka Bhotika
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