Start a conversation

Agent Is Installed but the Console Is Showing Installation Failed

Overview

EndPointSecurity agent is installed but the server console is showing under deployment: Installation failed!

The installation logs on the client will show installed successful but in the Logesecservice.csv file on the server shows the following:

2014-05-05, 11:01:58, 281, 2, 1330, 3, information, opdeployment, RemoteRegistry, OpenSubKey, Registry subkey opened.
2014-05-05, 11:01:58, 577, 1, 1330, 3, warning, opdeployment, DeploymentTask, Execute, Installation failed.
2014-05-05, 11:01:58, 577, 2, 1330, 3, information, opdeployment, DeploymentTask, OnStatus, OnSatus Error Running C34EDV08 100 Install StatusInstallationFailed

Environment

All versions

Root Cause

The agent MSI is showing a different version of the last updated toolcfg_updatehistory.xml file.

Resolution

  1. Close the EndPointSecurity console and stop the GFI EndPointSecurity service.

  2. Make the toolcfg_updatehistory.xml (found in Program Files (x86)\GFI\EndPointSecurity 6\Data\) file in another place.

  3. Replace the whole content of the toolcfg_updatehistory.xml (found in Program Files (x86)\GFI\EndPointSecurity 6\Data\) file with the following:
    <?xml version="1.0" encoding="utf-8"?>
    <ArrayOfUpdateHistoryEntry xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    </ArrayOfUpdateHistoryEntry>
  4. Run update.exe (found in Program Files (x86)\GFI\EndPointSecurity 6\). It should install the latest update (dated since 2014_04_01).

 

Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted

Comments