Start a conversation

Error Message: 'License Status: Failed to get status data from component' when viewing Licensing

Answer

PROBLEM

GFI WebMonitor generates the Error "Invalid license Key"
  • License Status: Failed to get status data from component[1].
  • Maintenance Agreement: Failed to get status data from component[2].
Associated Symptom: The WebGrade Database status is NOT enabled and Website categories are showing as unknown or uncategorized


ENVIRONMENT

  • GFI WebMonitor 
  • All supported versions


SOLUTION

Note: Ensure that the correct license key is in use for the appropriate build and version (Standalone Proxy or ISA/TMG) of GFI WebMonitor that is running
  1. From the Services Console, right-click the GFI WebMonitor Core Service and click Properties
  2. Select the Log On tab and under Log on as:, select This account
  3. Specify an account with administrative rights in the format of DOMAIN\UserName
  4. Provide the correct password for the specified account
  5. Click Apply and OK
  6. Restart the GFI WebMonitor Service
  • Ensure that Log on as a service rights have been set for GFI WebMonitor Service account
  1. Start > Run > type secpol.msc press Enter
  2. Expand Security Settings > Local Policies > User Rights Assignment
  3. Right-click Log on as a service from the right panel and click Properties
  4. Select the Local Security Setting tab
  5. Click Add User or Group button
  6. Key in the account name specified for the GFI WebMonitor Service and click OK
  7. Click Apply and OK
  8. Close all open windows
  9. Start > Run > type GPupdate /force > press Enter
  10. From the Services Console, restart the GFI WebMonitor Service


CAUSE

The logon account that the GFI WebMonitor Service is running as does not have the correct rights or the service is running under the Local System account.
Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted

Comments