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Fixing Errors: 'Unexpected error 26' and 'Cannot open database'

Overview

While the users try to access their data, no emails are shown in the mailbox and the following entries appear in the Error logs:

FolderIndexTraitsImpl.cpp: Index error in folder ~username@domain.com/INBOX: The database disk image is malformed 
FolderIndexTraitsImpl.cpp: Index error in folder ~username@domain.com/INBOX: Cannot open database
FolderIndexTraitsImpl.cpp: Index error in folder ~username@domain.com/INBOX: Unexpected error 26

error_26.png

The folder might be different from INBOX, such as Sent Items, Calendar, __cal__notify, Tasks, etc

folder_database.png

 


Prerequisites

Admin access to the Kerio Connect server is required.

 


Diagnosis

The internal database file that is responsible for Folder indexing became inconsistent or broken. The search.fld file for the affected folder is corrupted.

 

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Solution

  1. Stop the Kerio Connect service.

  2. Navigate to the Kerio store folder.

  3. Navigate to the user's folder reported in the log. For example: <kerio_store>/mail/<domain_name>/<username>/INBOX

  4. Delete the search.fld file.

    search_fld.png

  5. Start the Kerio Connect service.

  6. Re-index the mailbox of the affected user.

 

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Confirmation

The error log does not show the error entries.

 

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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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