Overview
Administrators can configure the Items Clean-Out feature which performs automatic user mailbox cleanup older than a specified time period, i.e. 30 days, to save space on the datastore disk.
Kerio Connect mailserver process runs the email account cleanup periodically based on message store size. Autodelete Clean-Out mails can be applied to Trash, Spam, Sent, and All folders (except Contacts and Notes).
The Item Clean-Out is looking at the date of the mails modification/manipulation, i.e. the timestamp when the email was moved to the folder, not the Creation date.
Prerequisites and Considerations
Access to Kerio Connect Administration
If you do not want to lose any messages with the Clean-out, archive or back-up the datastore.
Diagnosis
The Items clean-out feature works like a scheduled task and does not clean all relevant items at once. By default, it is set up to clean-out only 1000 items per folder at once, so that server performance is not affected. Therefore, the actual clean-out can take a while for large email folders.
However, you can increase the limit to delete more items per folder at once by following the steps mentioned below:
Notes:
- The Kerio Connect server should be stopped before modification.
- Please be advised that if the increase in limit leads to server performance issues, you must revert it to the default state.
-
Navigate to the Kerio Connect installation folder. The defaults are:
- Windows:
C:\Program Files\Kerio\MailServer
-
macOS:
/usr/local/kerio/mailserver
-
Linux:
/opt/kerio/mailserver
- Windows:
- Open the
mailserver.cfg
file. -
Navigate to the
<table name="MessageStore">
section. -
Change the value (1000 in the example below) of the variable
AutoDeleteFolderLimit
, as shown in this example:<variable name="AutoDeleteFolderLimit">1000</variable>
Solution
Per-Domain Settings
- In the administration interface, navigate to the Configuration > Domains section.
- Double-click on a domain.
- On the Messages tab, choose the folders for automatic clean-out and set the number of days.
- Click OK.
Per-User Settings
By default, new users inherit settings from their domain. To change the settings for individual users, follow the steps mentioned below:
- In the administration interface, navigate to the Accounts > Users section.
- Double-click on a user.
- Navigate to the Messages tab.
- In the Items Clean-Out section, select the Use custom settings for this user option.
- Select the folders for automatic clean-out and set the number of days.
- Click OK.
Confirmation
Emails are being autodeleted based on time period.
Priyanka Bhotika
Comments