Overview
When users in the domain have incorrect Calendar access rights or permissions in Kerio Connect, they are unable to access the calendar items that they are supposed to have access to and vice versa. Also, it might happen that the Contacts cannot be deleted over the CardDAV protocol.
This article describes the general process to handle the Calendar and Contacts corruption issues in Kerio Connect.
Prerequisites
You need to have the administrator rights to perform this process.
Root Cause
The .carddav and .caldav.db files in the database folders are corrupt.
Solution
NOTE: The same procedure applies to Resource Calendar issues.
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Navigate to the Kerio store directory.
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Navigate to the mail folder and create a backup of the following files:
- .carddav.db
- .carddav.db.bak
- .caldav.db
- .caldav.db.bak
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Delete the files mentioned in step 3.
NOTE: If the issue is only with Contacts, you can delete only the .carddav.db and .carddav.db.bak files. - (Optional) If there are some issues with the mobile device synchronization (over WebDAV and IMAP protocols), you can back up and delete the .pushdav.db and .pushimap.db files.
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Start the Kerio Connect service and allow some time to re-populate the files.
Related Articles
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