Start a conversation

Managed Attendant service related issues - ConfigurationServices Error: System resource exceeded

Answer

PROBLEM

The Managed Attendant service failed to read the configuration with the error ConfigurationServices: system resources exceeded.

The above issue can be observed in the following situations:
  • inbound emails are processed through the Microsoft Outbound plugins
  • Attendant does not stop when terminated through the Microsoft service control manager
  • Move to Microsoft Exchange functionality does not work
  • WebDAV Public folder training not processing any emails
  • Other Managed Attendant modules giving this or similar error: System resources exceeded
The ConfigurationServices.log would show:

"info   ","ConfigurationServices","Configuration::CreateInstance()"
"info   ","ConfigurationServices","Returning previous instance..."
"info   ","ConfigurationServices","Reading from database"
"error  ","ConfigurationServices","error: GetSerialNumber(): System resource exceeded."

ENVIRONMENT

  • GFI MailEssentials
  • all supported environments

SOLUTION

  • Microsoft Exchange 2003: Change the Public Folder training from WebDAV to IMAP
  • Microsoft Exchange 2007: Change the Public Folder training from WebDAV to Microsoft Exchange Web Services

CAUSE

The WEBDAV public folder training halts at one point and from then on, public folder training is re-invoked, spawning a new thread, but not processing anything (since the functionality is still in progress). The gap between the start of this problem and when the rest of the Managed Attendant starts to break is of anywhere between 4 and 8 or more days.
Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted

Comments