Start a conversation

Languard | Windows Core Operating Systems cannot be scanned

Summary

Languard Agent does not scan Server Core OS

Overview

Description

Languard Agent does not allow scanning of Server Core Operating Systems.

There are several software libraries that are required for our software to function that are not included in Server Core versions of the Operating System. 

Windows Server Core Operating Systems do not include a GUI, or software libraries that our dll files require to function, and we can not register the dll as a result.

Steps to reproduce 

  1. Deploy the GFI Languard Agent to the device using a Server Core OS from the Languard Console
  2. Attempt to perform an agent scan, either through scheduled agent scans, or using Refresh Information Now

Expected Results

  • When Agent is installed generally we are able to see the communication begin
  • Results should be reported back to console

Actual Results

  • Scan will not complete

Cause

Due to Server Core Operating systems not including all software libraries that are required for Languard Agents (No GUI, other software libraries missing) we are unable to register our DLL files and in turn the agent does not function

Workaround

None

Resolution

As the Server Core Operating System does not have the required software libraries to register our dll files, this prevents our agent from functioning on Server Core Operating Systems. 

Additional Information

An enhancement request was submitted to the Product Team under no.GFIL-3947 and has been closed without further information available.
Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted

Comments