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Shared Calendar is not visible

Overview

Users might not be able to see the Shared Calendar because of unexpected environmental issues, such as Kerio Connect server power outage, network issues, etc. The following messages appear in Warning logs:

Message index in folder ~john.doe@domain.com/Calendar/Kalendár is corrupted. Recovering index with redo log from indexlog.fld. 
Message index in folder ~john.doe@domain.com/Calendar/Kalendár successfully recovered (1 items changed). 
Restoring index in folder ~john.doe@domain.com/Calendar/Kalendár. Flags and status information may be lost.

Reindexing the mailbox procedure didn't help.

Prerequisites

Administrator (root) access to Kerio Connect server

Diagnosis

The internal configuration and status files became corrupted after the server outage. The sharing rights are stored in each user folder status.fld file, i.e. <kerio_connect_store>/mail/<domain>/<username>/Calendar/status.fld

status_fld.png

The last row starting with A letter contains the user email address Calendar is shared with or delegated to.

calendar_shared.png

The manual modification of the status.fld file requires the Kerio Connect server to be stopped. It might be not possible to stop the Kerio Connect during the working business day. In such cases, the re-share procedure can be applied.

Solution

  1. Unshare calendar of user john.doe
  2. Re-index the user mailbox
  3. Share calendar of user john.doe once again
  4. Subscribe to the calendar of john.doe from other users web clients

Confirmation

The Shared or Delegated Calendar appears in other users' Webmail.

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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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